$re = '/(?:^(?:<[^>]*>)?|\s)(he|lead[a-z]*)\b/im';
$str = 'Leading a team of 5.
You will be leading a team of 5
<span style="color:#f0f;">Leading a team of 5</span>
The code is ok
He is a good coder
test the leading test !@#$leading
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);