import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?:<[^>]*>)?|\\s)(he|lead[a-z]*)\\b";
final String string = "Leading a team of 5.\n"
+ "You will be leading a team of 5\n"
+ "<span style=\"color:#f0f;\">Leading a team of 5</span>\n"
+ "The code is ok\n"
+ "He is a good coder\n"
+ "test the leading test !@#$leading\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}