re = /(?:^(?:<[^>]*>)?|\s)(he|lead[a-z]*)\b/im
str = 'Leading a team of 5.
You will be leading a team of 5
<span style="color:#f0f;">Leading a team of 5</span>
The code is ok
He is a good coder
test the leading test !@#$leading
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end