// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(?:^(?:<[^>]*>)?|\s)(he|lead[a-z]*)\b").unwrap();
let string = "Leading a team of 5.
You will be leading a team of 5
<span style=\"color:#f0f;\">Leading a team of 5</span>
The code is ok
He is a good coder
test the leading test !@#$leading
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}