#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http[^\s]+(jpg|jpeg|png|webp)\b)"
Local $sString = " <picture>" & @CRLF & _
" <source type="image/webp" data-srcset="https://cdn.watchbase.com/caliber/md/origin:png/sellita/sw510-bh-b-2c.webp" srcset="https://assets.watchbase.com/img/FFFFFF-0.png" />" & @CRLF & _
" <img class="lazyload" data-src="https://cdn.watchbase.com/caliber/md/sellita/sw510-bh-b-2c.png" src="https://assets.watchbase.com/img/FFFFFF-0.png" alt="Sellita caliber SW510 BH b"/>" & @CRLF & _
" </picture>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")