$re = '/(http[^\s]+(jpg|jpeg|png|webp)\b)/m';
$str = ' <picture>
<source type="image/webp" data-srcset="https://cdn.watchbase.com/caliber/md/origin:png/sellita/sw510-bh-b-2c.webp" srcset="https://assets.watchbase.com/img/FFFFFF-0.png" />
<img class="lazyload" data-src="https://cdn.watchbase.com/caliber/md/sellita/sw510-bh-b-2c.png" src="https://assets.watchbase.com/img/FFFFFF-0.png" alt="Sellita caliber SW510 BH b"/>
</picture>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);