using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http[^\s]+(jpg|jpeg|png|webp)\b)";
string input = @" <picture>
<source type=""image/webp"" data-srcset=""https://cdn.watchbase.com/caliber/md/origin:png/sellita/sw510-bh-b-2c.webp"" srcset=""https://assets.watchbase.com/img/FFFFFF-0.png"" />
<img class=""lazyload"" data-src=""https://cdn.watchbase.com/caliber/md/sellita/sw510-bh-b-2c.png"" src=""https://assets.watchbase.com/img/FFFFFF-0.png"" alt=""Sellita caliber SW510 BH b""/>
</picture>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}