const regex = /(http[^\s]+(jpg|jpeg|png|webp)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[^\\s]+(jpg|jpeg|png|webp)\\b)', 'gm')
const str = ` <picture>
<source type="image/webp" data-srcset="https://cdn.watchbase.com/caliber/md/origin:png/sellita/sw510-bh-b-2c.webp" srcset="https://assets.watchbase.com/img/FFFFFF-0.png" />
<img class="lazyload" data-src="https://cdn.watchbase.com/caliber/md/sellita/sw510-bh-b-2c.png" src="https://assets.watchbase.com/img/FFFFFF-0.png" alt="Sellita caliber SW510 BH b"/>
</picture>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}