import re
regex = re.compile(r"(http[^\s]+(jpg|jpeg|png|webp)\b)", flags=re.MULTILINE)
test_str = (" <picture>\n"
" <source type=\"image/webp\" data-srcset=\"https://cdn.watchbase.com/caliber/md/origin:png/sellita/sw510-bh-b-2c.webp\" srcset=\"https://assets.watchbase.com/img/FFFFFF-0.png\" />\n"
" <img class=\"lazyload\" data-src=\"https://cdn.watchbase.com/caliber/md/sellita/sw510-bh-b-2c.png\" src=\"https://assets.watchbase.com/img/FFFFFF-0.png\" alt=\"Sellita caliber SW510 BH b\"/>\n"
" </picture>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")