import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "R(\\[-?[1-9][0-9]*\\])C(\\[-?[1-9][0-9]*\\])|R(\\[-?[1-9][0-9]*\\])C|RC(\\[-?[1-9][0-9]*\\])";
final String string = "RC\n"
+ "RC[1]\n"
+ "RC[-1]\n"
+ "R[1]C\n"
+ "R[-1]C\n"
+ "R[1]C[1]\n"
+ "R[-1]C[1]\n"
+ "R[1]C[-1]\n"
+ "R[-1]C[-1]\n"
+ "R[0]C[1]\n"
+ "RC[0]\n"
+ "R[1]C[0]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}