const regex = /R(\[-?[1-9][0-9]*\])C(\[-?[1-9][0-9]*\])|R(\[-?[1-9][0-9]*\])C|RC(\[-?[1-9][0-9]*\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('R(\\[-?[1-9][0-9]*\\])C(\\[-?[1-9][0-9]*\\])|R(\\[-?[1-9][0-9]*\\])C|RC(\\[-?[1-9][0-9]*\\])', 'g')
const str = `RC
RC[1]
RC[-1]
R[1]C
R[-1]C
R[1]C[1]
R[-1]C[1]
R[1]C[-1]
R[-1]C[-1]
R[0]C[1]
RC[0]
R[1]C[0]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}