import re
regex = re.compile(r"R(\[-?[1-9][0-9]*\])C(\[-?[1-9][0-9]*\])|R(\[-?[1-9][0-9]*\])C|RC(\[-?[1-9][0-9]*\])")
test_str = ("RC\n"
"RC[1]\n"
"RC[-1]\n"
"R[1]C\n"
"R[-1]C\n"
"R[1]C[1]\n"
"R[-1]C[1]\n"
"R[1]C[-1]\n"
"R[-1]C[-1]\n"
"R[0]C[1]\n"
"RC[0]\n"
"R[1]C[0]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")