// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"R(\[-?[1-9][0-9]*\])C(\[-?[1-9][0-9]*\])|R(\[-?[1-9][0-9]*\])C|RC(\[-?[1-9][0-9]*\])").unwrap();
let string = "RC
RC[1]
RC[-1]
R[1]C
R[-1]C
R[1]C[1]
R[-1]C[1]
R[1]C[-1]
R[-1]C[-1]
R[0]C[1]
RC[0]
R[1]C[0]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}