const regex = /^[\pZ\pC]+|[\pZ\pC]+$|(?! )[\pZ\pC]/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\pZ\\pC]+|[\\pZ\\pC]+$|(?! )[\\pZ\\pC]', 'gmu')
const str = ` abc def ghi `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);