import re
regex = re.compile(r"^[\pZ\pC]+|[\pZ\pC]+$|(?! )[\pZ\pC]", flags=re.MULTILINE | re.UNICODE)
test_str = " abc def ghi "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)