re = /^[\pZ\pC]+|[\pZ\pC]+$|(?! )[\pZ\pC]/m
str = ' abc def ghi '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result