use strict;
my $str = ' abc def ghi ';
my $regex = qr/^[\pZ\pC]+|[\pZ\pC]+$|(?! )[\pZ\pC]/mup;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";