$re = '/^[\pZ\pC]+|[\pZ\pC]+$|(?! )[\pZ\pC]/mu';
$str = ' abc def ghi ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;