#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<.+title="(.+?)"(.*)"
Local $sString = "<a href="http://google.com/" target="_self" title="TEXTDATA" class="encyclopedia">Google</a>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)