package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<.+title="(.+?)"(.*)`)
var str = `<a href="http://google.com/" target="_self" title="TEXTDATA" class="encyclopedia">Google</a>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}