// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<.+title="(.+?)"(.*)"#).unwrap();
let string = "<a href=\"http://google.com/\" target=\"_self\" title=\"TEXTDATA\" class=\"encyclopedia\">Google</a>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}