import re
regex = re.compile(r"<.+title=\"(.+?)\"(.*)", flags=re.MULTILINE)
test_str = "<a href=\"http://google.com/\" target=\"_self\" title=\"TEXTDATA\" class=\"encyclopedia\">Google</a>"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)