using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<.+title=""(.+?)""(.*)";
string substitution = @"$1";
string input = @"<a href=""http://google.com/"" target=""_self"" title=""TEXTDATA"" class=""encyclopedia"">Google</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}