re = /<.+title="(.+?)"(.*)/m
str = '<a href="http://google.com/" target="_self" title="TEXTDATA" class="encyclopedia">Google</a>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result