#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxs)(?<link_all>" & @CRLF & _
" (?<!\\)\[(?<link_name>.+?)(?<!\\)\]" & @CRLF & _
" [ ]?" & @CRLF & _
" (?:\n[ ]*)?" & @CRLF & _
" (?<!\\)\[(?<link_id>.*?)(?<!\\)\]" & @CRLF & _
")"
Local $sString = "Foo [bar] [1]." & @CRLF & _
"" & @CRLF & _
"Foo [bar][1]." & @CRLF & _
"" & @CRLF & _
"Foo [bar]" & @CRLF & _
"[1]." & @CRLF & _
"" & @CRLF & _
"Foo [bar][]" & @CRLF & _
"" & @CRLF & _
"[Foo\]][]" & @CRLF & _
"" & @CRLF & _
"Here's one where the [link" & @CRLF & _
"breaks][] across lines."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")