// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mxs)(?<link_all>
(?<!\\)\[(?<link_name>.+?)(?<!\\)\]
[ ]?
(?:\n[ ]*)?
(?<!\\)\[(?<link_id>.*?)(?<!\\)\]
)").unwrap();
let string = "Foo [bar] [1].
Foo [bar][1].
Foo [bar]
[1].
Foo [bar][]
[Foo\\]][]
Here's one where the [link
breaks][] across lines.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}