package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(?<link_all>
(?<!\\)\[(?<link_name>.+?)(?<!\\)\]
[ ]?
(?:\n[ ]*)?
(?<!\\)\[(?<link_id>.*?)(?<!\\)\]
)`)
var str = `Foo [bar] [1].
Foo [bar][1].
Foo [bar]
[1].
Foo [bar][]
[Foo\]][]
Here's one where the [link
breaks][] across lines.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}