$re = '/(?<link_all>
(?<!\\\\)\[(?<link_name>.+?)(?<!\\\\)\]
[ ]?
(?:\n[ ]*)?
(?<!\\\\)\[(?<link_id>.*?)(?<!\\\\)\]
)/mxs';
$str = 'Foo [bar] [1].
Foo [bar][1].
Foo [bar]
[1].
Foo [bar][]
[Foo\\]][]
Here\'s one where the [link
breaks][] across lines.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);