# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#(?=item\d)/./gm;t' <<< "#333 /*do not track*/
#ff0000 /*do not track*/
#item1 /*found*/
#item2 /*found*/
#item3 /*found*/"