import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(?=item\\d)";
final String string = "#333 /*do not track*/\n"
+ "#ff0000 /*do not track*/\n"
+ "#item1 /*found*/\n"
+ "#item2 /*found*/\n"
+ "#item3 /*found*/";
final String subst = ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}