#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)#(?=item\d)"
Local $sString = "#333 /*do not track*/" & @CRLF & _
"#ff0000 /*do not track*/" & @CRLF & _
"#item1 /*found*/" & @CRLF & _
"#item2 /*found*/" & @CRLF & _
"#item3 /*found*/"
Local $sSubst = "."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)