import Foundation
let pattern = ##"#(?=item\d)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#333 /*do not track*/
#ff0000 /*do not track*/
#item1 /*found*/
#item2 /*found*/
#item3 /*found*/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)