import re
regex = re.compile(r"#(?=item\d)", flags=re.MULTILINE)
test_str = ("#333 /*do not track*/\n"
"#ff0000 /*do not track*/\n"
"#item1 /*found*/\n"
"#item2 /*found*/\n"
"#item3 /*found*/")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)