re = /#(?=item\d)/m
str = '#333 /*do not track*/
#ff0000 /*do not track*/
#item1 /*found*/
#item2 /*found*/
#item3 /*found*/'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result