# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?::.+(?=;))?(\s+)/ /gm;t' <<< "body {
border-collapse: collapse;
border-spacing: 6px;
border:none;
font-family: Tahoma, Arial, sans-serif;
font-size: 12px;
padding: 6px;
border-bottom: 1px solid #ccc;
}
p {
color:red;
box-shadow: rgba(0, 0, 0, 0.1) 0px 4px 12px;
}"