import re
regex = re.compile(r"(?::.+(?=;))?(\s+)", flags=re.MULTILINE)
test_str = ("body {\n\n"
"border-collapse: collapse;\n"
" border-spacing: 6px;\n"
" border:none;\n"
" font-family: Tahoma, Arial, sans-serif;\n"
" font-size: 12px;\n"
" padding: 6px;\n"
" border-bottom: 1px solid #ccc;\n"
"}\n\n"
"p {\n"
"color:red;\n"
"box-shadow: rgba(0, 0, 0, 0.1) 0px 4px 12px;\n"
"}")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)