use strict;
my $str = 'body {
border-collapse: collapse;
border-spacing: 6px;
border:none;
font-family: Tahoma, Arial, sans-serif;
font-size: 12px;
padding: 6px;
border-bottom: 1px solid #ccc;
}
p {
color:red;
box-shadow: rgba(0, 0, 0, 0.1) 0px 4px 12px;
}';
my $regex = qr/(?::.+(?=;))?(\s+)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";