re = /(?::.+(?=;))?(\s+)/m
str = 'body {
border-collapse: collapse;
border-spacing: 6px;
border:none;
font-family: Tahoma, Arial, sans-serif;
font-size: 12px;
padding: 6px;
border-bottom: 1px solid #ccc;
}
p {
color:red;
box-shadow: rgba(0, 0, 0, 0.1) 0px 4px 12px;
}'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result