package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<number_of_elements>\*\d)\\r\\n((\$\d)\\r\\n(\w+)\\r\\n)*`)
var str = `*2\r\n$5\r\nhello\r\n$5\r\nworld\r\n
*0\r\n
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}