// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<number_of_elements>\*\d)\\r\\n((\$\d)\\r\\n(\w+)\\r\\n)*").unwrap();
let string = "*2\\r\\n$5\\r\\nhello\\r\\n$5\\r\\nworld\\r\\n
*0\\r\\n
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}