import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<number_of_elements>\\*\\d)\\\\r\\\\n((\\$\\d)\\\\r\\\\n(\\w+)\\\\r\\\\n)*";
final String string = "*2\\r\\n$5\\r\\nhello\\r\\n$5\\r\\nworld\\r\\n\n"
+ "*0\\r\\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}