$re = '/(?P<number_of_elements>\*\d)\\\\r\\\\n((\$\d)\\\\r\\\\n(\w+)\\\\r\\\\n)*/m';
$str = '*2\\r\\n$5\\r\\nhello\\r\\n$5\\r\\nworld\\r\\n
*0\\r\\n
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);