use strict;
my $str = 'TILL: LOOK we\'ve got like a new bOArd';
my $regex = qr/^([A-Z]+:)|[A-Z]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";