import re
regex = re.compile(r"^([A-Z]+:)|[A-Z]+", flags=re.MULTILINE)
test_str = "TILL: LOOK we've got like a new bOArd"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)