$re = '/^([A-Z]+:)|[A-Z]+/m';
$str = 'TILL: LOOK we\'ve got like a new bOArd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;