#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)@import[ ]*['\"]{0,}(url\()*['\"]*([^;'\"\)]*)['\"\)]*"
Local $sString = "@import "font-awesome.min.css";" & @CRLF & _
"@import "simple-line-icons.css";" & @CRLF & _
"@import url(http://fonts.googleapis.com/css?family=Montserrat:700,400);" & @CRLF & _
"@import url('http://fonts.googleapis.com/css?family=ggg');" & @CRLF & _
"@import url("http://fonts.googleapis.com/css?family=ggg");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")