re = /@import[ ]*['\"]{0,}(url\()*['\"]*([^;'\"\)]*)['\"\)]*/i
str = '@import "font-awesome.min.css";
@import "simple-line-icons.css";
@import url(http://fonts.googleapis.com/css?family=Montserrat:700,400);
@import url(\'http://fonts.googleapis.com/css?family=ggg\');
@import url("http://fonts.googleapis.com/css?family=ggg");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end