import re
regex = re.compile(r"@import[ ]*['\"]{0,}(url\()*['\"]*([^;'\"\)]*)['\"\)]*", flags=re.IGNORECASE)
test_str = ("@import \"font-awesome.min.css\";\n"
"@import \"simple-line-icons.css\";\n"
"@import url(http://fonts.googleapis.com/css?family=Montserrat:700,400);\n"
"@import url('http://fonts.googleapis.com/css?family=ggg');\n"
"@import url(\"http://fonts.googleapis.com/css?family=ggg\");")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")