package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)@import[ ]*['\"]{0,}(url\()*['\"]*([^;'\"\)]*)['\"\)]*`)
var str = `@import "font-awesome.min.css";
@import "simple-line-icons.css";
@import url(http://fonts.googleapis.com/css?family=Montserrat:700,400);
@import url('http://fonts.googleapis.com/css?family=ggg');
@import url("http://fonts.googleapis.com/css?family=ggg");`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}