using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@import[ ]*['\""]{0,}(url\()*['\""]*([^;'\""\)]*)['\""\)]*";
string input = @"@import ""font-awesome.min.css"";
@import ""simple-line-icons.css"";
@import url(http://fonts.googleapis.com/css?family=Montserrat:700,400);
@import url('http://fonts.googleapis.com/css?family=ggg');
@import url(""http://fonts.googleapis.com/css?family=ggg"");";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}